Blog

Adobe

CVE-2018-4878 – Adobe Flash Player use after free (Zero Day) vulnerability Alert!

 February 3, 2018

Estimated reading time: 1 minute

The recent zero-day vulnerability CVE-2018-4878 in Adobe Flash Player enables attackers to perform a Remote Code Execution on targeted machines. Adobe has released a security advisory APSA18-01 on February 2, 2018 to address this issue. According to Adobe, the in-wild attack is targeted and it impacts limited Windows users. Vulnerable...

Potentially Unwanted Applications (PUAs) in Disguise of Software Updates

  • 3
    Shares
 March 21, 2016

Estimated reading time: 5 minutes

It has been observed that cyber criminals are using genuine names to enter into their targeted victim’s system. They are doing this by displaying random pop-up ads on Internet Explorer, Firefox, or Google Chrome that prompts the user to update Adobe Flash Player, Java, media players, etc. These pop-up ads...

This Week’s Latest IT Security News and Updates

 February 7, 2014

Estimated reading time: 2 minutes

Beware of Emails Containing Free FIFA Tickets Malware artists sure are opportunistic. News are up that they are using the FIFA bait to lure their victims. Reportedly, users are receiving emails notifying them that they have won free tickets to 20th FIFA World Cup. The emails contain links to a...

This Week’s Bytes of the Latest IT Security News and Updates

 October 5, 2013

Estimated reading time: 2 minutes

Adobe Hacked – Data of 2.9 million Customers Compromised! Adobe has announced in its blog of a major security breach that compromised the data of 2.9 million of its customers. According to the company’s chief security officer, the hacked data mainly included customer IDs, encrypted passwords, encrypted credit and debit...

Security update available for Adobe Flash Player

 March 6, 2012

Estimated reading time: 1 minute

These updates address critical vulnerabilities in Adobe Flash Player 11.1.102.62 and earlier versions for Windows, Macintosh, Linux and Solaris, Adobe Flash Player 11.1.115.6 and earlier versions for Android 4.x and Adobe Flash Player 11.1.111.6 and earlier versions for Android 3.x and 2.x. These vulnerabilities could cause a crash and potentially...

Security updates available for Adobe Reader and Acrobat

 January 12, 2012

Estimated reading time: 2 minutes

A critical vulnerability has been identified in Adobe Reader X (10.1.1) and earlier versions for Windows and Macintosh and in Adobe Acrobat X (10.1.1) and earlier versions for Windows and Macintosh. These vulnerabilities could cause the application to crash and potentially allow an attacker to gain control of the affected...

Security Advisory for Adobe Reader and Acrobat!

 December 18, 2011

Estimated reading time: 1 minute

A critical vulnerability has been identified in Adobe Reader X (10.1.1) and earlier versions for Windows and Macintosh, Adobe Reader 9.4.6 and earlier 9.x versions for UNIX and Adobe Acrobat X (10.1.1) and earlier versions for Windows and Macintosh. This vulnerability (CVE-2011-2462) could cause a crash and potentially allow an...

Fake emails – Adobe Critical Upgrade

 December 7, 2011

Estimated reading time: 1 minute

A new fake email which pretends to be from Adobe is in the wild and spreading on the Internet. The email has an attachment which contains an executable file having PDF icon. If the user gets convinced by this email and executes the file the computer gets infected. The sample...

Surfing the Internet the secure way with browser sandbox

  • 1
    Share
 November 1, 2011

Estimated reading time: 2 minutes

PC’s today are mostly victims of infections caused by visiting infected websites that drop malware codes. Even though we have website reputation checks implemented by all anti-malware software, there is always a slight chance that the user may visit a newly infected website that has not yet been classified as...

Adobe Flash Player security update

 September 23, 2011

Estimated reading time: 1 minute

Adobe has released a security patch for Adobe Flash Player that fixes several critical security vulnerabilities. Affected are all versions of Adobe Flash Player 10.3.183.7 and earlier, for all supported operating systems (Windows, Macintosh, Linux, Solaris) as well as Adobe Flash Player 10.3.186.6 and earlier for the Android operating system....